Wednesday, January 27, 2016

Full Bandwidth Management Parent Queue Tree Mikrotik

Full Bandwidth Management Parent Queue Tree



This is the combination, continued and completion of bandwidth management methods previously using parent queue tree about to handle all sorts of purposes in an internet network that is more complex. Perhaps if you do not want to think too hard, you simply apply the simple queue to limit bandwidth that so powerful and assertive to limit bandwidth per client on your internet network. The problem is if we share the bandwidth with a simple queue is stiffness, and it's hard for me to divide into many clients normally. It would be appropriate to be applied to the kind of dedicate internet connection.


For example If I have a totally the bandwidth internet connection is up to 2M, after i have tested by speed test, the bandwidth average is 512 kbps. It means that if I have 6 clients, be 512/6 = 86 kbps/clients normally, the ideal number is very small inappropriate for our client. If the bandwidth of up to 2 M calculated with 2000/6 to be around 334 kbps /clients, it can makes browsing and online game stuck if just only one client there who download and play streaming video, because the client spend almost all the average speed (512kbps) other clients will be especially problematic just for browsing or online game. In this case we need the priority to the fourth packets.

Full Bandwidth Management with the parent queue tree complete the lack of packets connection per client, especially to handle the internet network with many clients. The principle is equally divide the bandwidth to all the clients with bandwidth greater than that should be given as the limit bandwidth on each clients, in which we set Online Games, Browsing, Download, Video Streaming packets, connection packets. Well, for now I will make the Full BandwidthManagement using the parent queue tree. For more easily to make the complex rule, I will work with the scripts for more quickly.


Situation and Conditions:

Total Bandwidth = Up to 2 M

8 Clients that I have :
Billing : 192.168.1.11
Client1    : 192.168.1.17
Client2    : 192.168.1.16
Client3    : 192.168.1.15
Client4    : 192.168.1.14
Client5    : 192.168.1.20
Client6    : 192.168.1.21
Master    : 192.168.1.8 

In-Interface = ether1
Out-Interface = wlan1

/ip firewall address-list
add address=192.168.1.0/24  disabled=no list=MikroTik comment=""

1.      Marking all the connection out and in of the interface Mikrotik router, and create the connection


The connection that we will use is All-Outconn as the above scripts with the connection chain=forwardout-interface=wlan1, which we subsequently differentiate into different connections to produce different connection packets.

2. Take the connections of All-Outconn then divide it into the connections to every client, and make connection packets every client that will captured by the queue tree per client.
Here are the following scripts :
/ip firewall mangle
addaction=mark-connectionchain=forwardcomment="Billing"disabled=nodst-address=192.168.1.11 new-connection-mark=Billing-conn passthrough=yes connection-mark=All-Outconn
addaction=mark-connectionchain=forwardcomment="Client1"disabled=nodst-address=192.168.1.17 new-connection-mark=Client1-conn passthrough=yes connection-mark=All-Outconn
addaction=mark-connectionchain=forwardcomment="Client2"disabled=nodst-address=192.168.1.16 new-connection-mark=Client2-conn passthrough=yes connection-mark=All-Outconn
addaction=mark-connectionchain=forwardcomment="Client3"disabled=nodst-address=192.168.1.15 new-connection-mark=Client3-conn passthrough=yes connection-mark=All-Outconn
addaction=mark-connectionchain=forwardcomment="Client4"disabled=nodst-address=192.168.1.14 new-connection-mark=Client4-conn passthrough=yes connection-mark=All-Outconn
addaction=mark-connectionchain=forwardcomment="Client5"disabled=nodst-address=192.168.1.20 new-connection-mark=Client5-conn passthrough=yes connection-mark=All-Outconn
addaction=mark-connectionchain=forwardcomment="Client6"disabled=nodst-address=192.168.1.21 new-connection-mark=Client6-conn passthrough=yes connection-mark=All-Outconn
addaction=mark-connectionchain=forwardcomment="Master"disabled=nodst-address=192.168.1.8 new-connection-mark=Master-conn passthrough=yes connection-mark=All-Outconn

/ip firewall mangle
addaction=mark-packet chain=forwardnew-packet-mark=Billing-pktpassthrough=yes connection-mark=Billing-conn comment="BILLING DOWNSTEAM"
addaction=mark-packet chain=forwardnew-packet-mark=Client1-pkt passthrough=yes connection-mark=Client1-conn comment="CLIENT1 DOWNSTEAM"
addaction=mark-packet chain=forwardnew-packet-mark=Client2-pkt passthrough=yes connection-mark=Client2-conn comment="CLIENT2 DOWNSTEAM"
addaction=mark-packet chain=forwardnew-packet-mark=Client3-pkt passthrough=yes connection-mark=Client3-conn comment="CLIENT3 DOWNSTEAM"
addaction=mark-packet chain=forwardnew-packet-mark=Client4-pkt passthrough=yes connection-mark=Client4-conn comment="CLIENT4 DOWNSTEAM"
addaction=mark-packet chain=forwardnew-packet-mark=Client5-pkt passthrough=yes connection-mark=Client5-conn comment="CLIENT5 DOWNSTEAM"
addaction=mark-packet chain=forwardnew-packet-mark=Client6-pkt passthrough=yes connection-mark=Client6-conn comment="CLIENT6 DOWNSTEAM"
addaction=mark-packet chain=forwardnew-packet-mark=Master-pktpassthrough=yes connection-mark=Master-conn comment="MASTER DOWNSTEAM"

/queue tree
addname=Billing parent=All-Bandwidth packet-mark=Billing-pkt queue=defaultpriority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname=Client1 parent=All-Bandwidth packet-mark=Client1-pkt queue=defaultpriority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname=Client2 parent=All-Bandwidth packet-mark=Client2-pkt queue=defaultpriority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname=Client3 parent=All-Bandwidth packet-mark=Client3-pkt queue=defaultpriority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname=Client4 parent=All-Bandwidth packet-mark=Client4-pkt queue=defaultpriority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname=Client5 parent=All-Bandwidth packet-mark=Client5-pkt queue=defaultpriority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname=Client6 parent=All-Bandwidth packet-mark=Client6-pkt queue=defaultpriority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname=Master parent=All-Bandwidth packet-mark=Master-pkt queue=defaultpriority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s


The scripts above consists with mangle and queue tree rule. From here we are already making the connections per ip address of clients, such as
  • Connections Per Client : Billing-conn, Client1-conn, Client2-conn, Client3-conn, Client4-conn, Client5-conn, Client6-conn, Master-conn
  • Connection Packets Per Client : Billing-pkt, Client1-pkt, Client1-pkt, Client2-pkt, Client3-pkt, Client4-pkt, Client5-pkt, Client6-pkt, Master-pkt

3. The Connections per client that we have divided will separated into four packets connection such as browsing, online games, download, streaming video per client. Here are the forth part of four different packets connection. If there are any packets that have not been defined I asked for suggestions from those of you that had experience.

Part I : Making the packets per client for download and the queue tree with priority as you wish, here the following scripts:
/ip firewall layer7-protocol
addcomment=""name=download regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"

/ip firewall mangle
addchain=forwardlayer7-protocol=download action=mark-packet new-packet-mark=billing-dpktpassthrough=nopacket-mark=Billing-pkt comment=Billing-Down
addchain=forwardlayer7-protocol=download action=mark-packet new-packet-mark=client1-dpkt passthrough=nopacket-mark=Client1-pkt comment=Client1-Down
addchain=forwardlayer7-protocol=download action=mark-packet new-packet-mark=client2-dpkt passthrough=nopacket-mark=Client2-pkt comment=Client2-Down
addchain=forwardlayer7-protocol=download action=mark-packet new-packet-mark=client3-dpkt passthrough=nopacket-mark=Client3-pkt comment=Client3-Down
addchain=forwardlayer7-protocol=download action=mark-packet new-packet-mark=client4-dpkt passthrough=nopacket-mark=Client4-pkt comment=Client4-Down
addchain=forwardlayer7-protocol=download action=mark-packet new-packet-mark=client5-dpkt passthrough=nopacket-mark=Client5-pkt comment=Client5-Down
addchain=forwardlayer7-protocol=download action=mark-packet new-packet-mark=client6-dpkt passthrough=nopacket-mark=Client6-pkt comment=Client6-Down
addchain=forwardlayer7-protocol=download action=mark-packet new-packet-mark=master-dpktpassthrough=nopacket-mark=Master-pkt comment=Master-Down
  
/queue tree
addname=Billing-Down parent=Billing packet-mark=billing-dpkt queue=defaultpriority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
addname=Client1-Down parent=Client1 packet-mark=client1-dpkt queue=defaultpriority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
addname=Client2-Down parent=Client2 packet-mark=client2-dpkt queue=defaultpriority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
addname=Client3-Down parent=Client3 packet-mark=client3-dpkt queue=defaultpriority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
addname=Client4-Down parent=Client4 packet-mark=client4-dpkt queue=defaultpriority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
addname=Client5-Down parent=Client5 packet-mark=client5-dpkt queue=defaultpriority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
addname=Client6-Down parent=Client6 packet-mark=client6-dpkt queue=defaultpriority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
addname=Master-Down parent=Master packet-mark=master-dpkt queue=defaultpriority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s

Here we take and use the connections per client and differentiate into connection packets of downloaded by the extension files, so if there are any the extension files that you think is important, just add the the extension files that you want to the layer 7 protocols from the above scripts.

Part II. Making the video packet connection per client complete with the queue tree and priority as you please. Here the following scripts
add comment="" name=streaming regexp="^.*get.+\\.(c.youtube.com|cdn.dailymotion.com|metacafe.com|mccont.com).*\$"
If the above script doesn't works, try the second regexp on the script below!
/ip firewall layer7-protocol
add comment="" name=streaming regexp="videoplayback|video"
/ip firewall mangle
addcomment=Billing-Streams chain=forwardlayer7-protocol=streaming action=mark-packet new-packet-mark=billing-spktpassthrough=nopacket-mark=Billing-pkt
addcomment=Client1-Streams chain=forwardlayer7-protocol=streaming action=mark-packet new-packet-mark=client1-spkt passthrough=nopacket-mark=Client1-pkt
addcomment=Client2-Streams chain=forwardlayer7-protocol=streaming action=mark-packet new-packet-mark=client2-spkt passthrough=nopacket-mark=Client2-pkt
addcomment=Client3-Streams chain=forwardlayer7-protocol=streaming action=mark-packet new-packet-mark=client3-spkt passthrough=nopacket-mark=Client3-pkt
addcomment=Client4-Streams chain=forwardlayer7-protocol=streaming action=mark-packet new-packet-mark=client4-spkt passthrough=nopacket-mark=Client4-pkt
addcomment=Client5-Streams chain=forwardlayer7-protocol=streaming action=mark-packet new-packet-mark=client5-spkt passthrough=nopacket-mark=Client5-pkt
addcomment=Client6-Streams chain=forwardlayer7-protocol=streaming action=mark-packet new-packet-mark=client6-spkt passthrough=nopacket-mark=Client6-pkt
addcomment=Master-Streams chain=forwardlayer7-protocol=streaming action=mark-packet new-packet-mark=master-spktpassthrough=nopacket-mark=Master-pkt
  
/queue tree
addname=Billing-Streams parent=Billing packet-mark=billing-spkt queue=defaultpriority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client1-Streams parent=Client1 packet-mark=client1-spkt queue=defaultpriority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client2-Streams parent=Client2 packet-mark=client2-spkt queue=defaultpriority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client3-Streams parent=Client3 packet-mark=client3-spkt queue=defaultpriority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client4-Streams parent=Client4 packet-mark=client4-spkt queue=defaultpriority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client5-Streams parent=Client5 packet-mark=client5-spkt queue=defaultpriority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client6-Streams parent=Client6 packet-mark=client6-spkt queue=defaultpriority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Master-Streams parent=Master packet-mark=master-spkt queue=defaultpriority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s

This is the similar method in making the connection packets like download packets is by using a layer 7 protocols, the content of streaming video other sites that have not been defined, please you add on the layer 7 protocols if you think that is important, and adjust the priority and limit speed on the queue tree as you please.

c. Membuat packets Online game per client lengkapdengan queue treenya, berikutiniadalahscriptsnya :

Part III : Making the Online games packet connection per client complete with the queue tree and priority, here the following scripts:
/ip firewall mangle
addaction=mark-packet chain=forwardpacket-mark=All-Outpkt new-packet-mark=gpktpassthrough=yes protocol=tcpdst-port=5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 comment="Online Game Portal"
addaction=mark-packet chain=forwardpacket-mark=All-Outpkt new-packet-mark=gpktpassthrough=yes protocol=tcp dst-port=39190,27780,29000,22100,10009,4300,15001,15002,7341,7451
addaction=mark-packet chain=forwardpacket-mark=All-Outpkt new-packet-mark=gpktpassthrough=yes protocol=tcpdst-port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822
addaction=mark-packet chain=forwardpacket-mark=All-Outpkt new-packet-mark=gpktpassthrough=yes protocol=tcpdst-port=47611,16666,20000,5105,29000,18901-18909,9015
addaction=mark-packet chain=forwardpacket-mark=All-Outpkt new-packet-mark=gpktpassthrough=yes protocol=udpdst-port=27005,27015
addaction=mark-packet chain=forwardpacket-mark=All-Outpkt new-packet-mark=gpktpassthrough=yes protocol=udpdst-port=27005-27020,13055,7800-7900,12060-12070
addaction=mark-packet chain=forwardpacket-mark=All-Outpkt new-packet-mark=gpktpassthrough=yes protocol=udpdst-port=8005-8010,9068,1293,1479,9401,9600,30000
addaction=mark-packet chain=forwardpacket-mark=All-Outpkt new-packet-mark=gpktpassthrough=yes protocol=udpdst-port=14009-14030,42051-42052,40000-40050,13000-13080

/ip firewall mangle
addaction=mark-packet chain=forwardnew-packet-mark=billing-gpktpassthrough=nodst-address=192.168.1.11 packet-mark=gpkt comment=Billing-Game
addaction=mark-packet chain=forwardnew-packet-mark=client1-gpkt passthrough=nodst-address=192.168.1.17 packet-mark=gpkt comment=Client1-Game
addaction=mark-packet chain=forwardnew-packet-mark=client2-gpkt passthrough=nodst-address=192.168.1.16 packet-mark=gpkt comment=Client2-Game
addaction=mark-packet chain=forwardnew-packet-mark=client3-gpkt passthrough=nodst-address=192.168.1.15 packet-mark=gpkt comment=Client3-Game
addaction=mark-packet chain=forwardnew-packet-mark=client4-gpkt passthrough=nodst-address=192.168.1.14 packet-mark=gpkt comment=Client4-Game
addaction=mark-packet chain=forwardnew-packet-mark=client5-gpkt passthrough=nodst-address=192.168.1.20 packet-mark=gpkt comment=Client5-Game
addaction=mark-packet chain=forwardnew-packet-mark=client6-gpkt passthrough=nodst-address=192.168.1.21 packet-mark=gpkt comment=Client6-Game
addaction=mark-packet chain=forwardnew-packet-mark=master-gpktpassthrough=nodst-address=192.168.1.8 packet-mark=gpkt comment=Master-Game

/queue tree
addname=Billing-Game parent=Billing packet-mark=billing-gpkt queue=defaultpriority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client1-Game parent=Client1 packet-mark=client1-gpkt queue=defaultpriority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client2-Game parent=Client2 packet-mark=client2-gpkt queue=defaultpriority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client3-Game parent=Client3 packet-mark=client3-gpkt queue=defaultpriority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client4-Game parent=Client4 packet-mark=client4-gpkt queue=defaultpriority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client5-Game parent=Client5 packet-mark=client5-gpkt queue=defaultpriority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Client6-Game parent=Client6 packet-mark=client6-gpkt queue=defaultpriority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
addname=Master-Game parent=Master packet-mark=master-gpkt queue=defaultpriority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s

In this case we make the online-games connection at first, based on out-interface=wlan1 and tcp and udp of many ports that used by the online games. Then make the online games connection packets per ip address client from that, finally we capture the packets online games on queue tree and the priority as you wish.

Part IV. Make browsing connection packets per client complete with tree queue and give the priority, here the following script :
/ip firewall mangle
addaction=mark-packet chain=forwardconnection-bytes=0-1000000 src-port=80,443 passthrough=nopacket-mark=Billing-pkt new-packet-mark=billing-bpkt protocol=tcp comment="BILLING BROWSING"
addaction=mark-packet chain=forwardconnection-bytes=0-1000000 src-port=80,443 passthrough=nopacket-mark=Client1-pkt new-packet-mark=client1-bpkt protocol=tcp comment="CLIENT1 BROWSING"
addaction=mark-packet chain=forwardconnection-bytes=0-1000000 src-port=80,443 passthrough=nopacket-mark=Client2-pkt new-packet-mark=client2-bpkt protocol=tcp comment="CLIENT2 BROWSING"
addaction=mark-packet chain=forwardconnection-bytes=0-1000000 src-port=80,443 passthrough=nopacket-mark=Client3-pkt new-packet-mark=client3-bpkt protocol=tcp comment="CLIENT3 BROWSING"
addaction=mark-packet chain=forwardconnection-bytes=0-1000000 src-port=80,443 passthrough=nopacket-mark=Client4-pkt new-packet-mark=client4-bpkt protocol=tcp comment="CLIENT4 BROWSING"
addaction=mark-packet chain=forwardconnection-bytes=0-1000000 src-port=80,443 passthrough=nopacket-mark=Client5-pkt new-packet-mark=client5-bpkt protocol=tcp comment="CLIENT5 BROWSING"
addaction=mark-packet chain=forwardconnection-bytes=0-1000000 src-port=80,443 passthrough=nopacket-mark=Client6-pkt new-packet-mark=client6-bpkt protocol=tcp comment="CLIENT6 BROWSING"
addaction=mark-packet chain=forwardconnection-bytes=0-1000000 src-port=80,443 passthrough=nopacket-mark=Master-pkt new-packet-mark=master-bpkt protocol=tcp comment="MASTER BROWSING"

/queue tree
addname="Billing-Browsing"parent=Billing packet-mark=billing-bpkt queue=defaultpriority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname="Client1-Browsing"parent=Client1 packet-mark=client1-bpkt queue=defaultpriority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname="Client2-Browsing"parent=Client2 packet-mark=client2-bpkt queue=defaultpriority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname="Client3-Browsing"parent=Client3 packet-mark=client3-bpkt queue=defaultpriority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname="Client4-Browsing"parent=Client4 packet-mark=client4-bpkt queue=defaultpriority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname="Client5-Browsing"parent=Client5 packet-mark=client5-bpkt queue=defaultpriority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname="Client6-Browsing"parent=Client6 packet-mark=client6-bpkt queue=defaultpriority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
addname="Master-Browsing"parent=Master packet-mark=master-bpkt queue=defaultpriority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
Take and use the connection per client then we make the new browsing connection by capturing based on port 80 and 443 (HTTP and HTTPS ports) and adding small bytes connection-bytes=0-1000000, port that commonly used in browsing the url site, small bytes of data may also be included here from the other three connection packets else, but small enough




 

Saturday, January 23, 2016

Setting HTB Mikrotik Untuk Bandwidth Management

Semua tutor yang ada di internet sudah penulis coba mulai dari Simple Queue, PCQ dan lain2 tutor yg banyak bertebaran di internet. tp tidak satu pun yg sesuai keinginan penulis.

Contoh 1 : saat penulis menggunakan bandwidth management simple queue pada warnet (misal user A di limit 512k) maka sepanjang waktu user tsb akan mendapatkan bandwidth hanya 512k dan akan terus seperti itu.
Walaupun mungkin warnet tsb sepi dan tidak ada yg menggunakan bandwidth. Lalu sisa bandwidth yg 2,5mbps nya buat apa ? tentu akan mubazir begitu saja jika tidak digunakan, sedangkan anda tetap harus bayar bandwidth 3Mb per bulan.
Contoh 2 : di percobaan lain penulis mencoba menggunakan bandwdith management PCQ. embel2 didepannya sangat bagus, yaitu membagi bandwidth menjadi rata (bandwdith dinamis).
Gambarannya : misal warnet anda 3mbps dan anda mempunyai 10 user. dengan metode  bandwidth management PCQ dikatakan bahwa apabila 1 User online sendirian maka user tsb akan mendapat bandwidth 3mbps, jika 3 User yg online maka bandwidth akan terbagi rata menjadi 1mbps per user nya (3mbps/3user = 1mbps per user) dan seterusnya hingga 10 User online bersamaan maka tiap user akan mendapat 300kbps per user nya. tentu saja dgn keunggulan metode PCQ tsb diatas penulis mencoba menerapkan bandwidth management tsb dan menemukan beberapa hal yg menurut penulis masih kurang cocok untuk diterapkan di warnet, kantor maupun jaringan lainnya.
Masalah 1 PCQ :
Metode PCQ tidak mendefinisikan Queue per user, jadi hanya membuat queue secara global untuk seluruh user jaringan. sehingga penulis jd tidak tau bahwa sebetulnya bandwidth yang dikonsumsi oleh masing2 user itu berapa.
Lalu masalah lain adalah penulis tidak akan pernah tau apakah bandwidth tsb benar2 terbagi rata atau tidak. atau apakah bandwidth management PCQ yg dikatakan dapat benar2 membagi bandwidth menjadi rata tsb betul atau tidak.
Seperti disebutkan diatas, bandwidth management PCQ hanya mendefinisikan penggunaan bandwidth global bukan per User (per IP).
Masalah 2 PCQ : penulis coba mengetest pada beberapa user dgn perilaku penggunaan internet yg berbeda, misal : User A menggunakan IDM, user B maen game, User C hanya browsing biasa, User D streaming youtube.
Hasilnya adalah User A yang menggunakan IDM akan selalu mendominasi penggunaan bandwidth atau serakah dalam menggunakan bandwidth sehingga user lain akan selalu merasa kehabisan bandwidth (baca: lag) karena bandwidth akan habis disedot oleh User A yg menggunakan IDM (istilah bandwidth management bolong/bocor).
Masalah 3 PCQ : repotnya lagi saat penulis mencoba menerapkan bandwidth management PCQ seperti diatas (masalah 2 PCQ) ping akan melonjak membesar (ratusan/ribuan digit) bahkan bisa menjadi request time out (RTO) karena ketidakstabilan ping pada jaringan disebabkan beberapa user menggunakan heavy bandwidth misal IDM, Streaming dan lain2.
Dengan masalah tsb tentunya metode ini tidak mungkin diterapkan oleh penulis di warnet, karena warnet terutama warnet game akan membutuhkan ping yang stabil dan kecil. (catatan : game hanya butuh ping yg kecil dan stabil, bukan bandwidth besar).

Bandwidth Management Mikrotik with HTB
Hingga akhirnya penulis menemukan artikel tentang HTB mikrotik di sini :
HTB Mikrotik
Penulis tidak akan membahas banyak artikel tsb, karena tidak terlalu jelas langkah/tutorial dan cara untuk menerapkan HTB di artikel tsb, hingga akhirnya penulis mencoba menterjemahkan sendiri maksud dari artikel Bung Valens tsb dan mengimplementasikannya dengan modal trial error.
Seperti di metode bandwidth management sebelumnya, penulis mencoba eksperimen dgn bermodal artikel diatas. dan Alhamdulillah akhirnya sesuai dgn harapan penulis untuk metode Bandwidth Management Dinamis yg efektif.
untuk metode Bandwidth Management Mikrotik HTB penulis mencoba mengambil beberapa point sbb :
- Metode ini sangat jelas definisi penggunaan bandwdith tiap user karena metode ini bisa di implementasikan sampai level bawah ( per IP User)
- Sesuai dgn artikel bung valen diatas bahwa pembagian bandwidth memang betul2 dapat terbagi rata.
anda tidak percaya ? berikut saya berikan salah satu contoh buktinya
Bandwidth Management HTB
- Bandwidth Management Mikrotik HTB tidak bisa ditembus oleh IDM, DAP, Streaming atau aplikasi download accelerator. jd jika penulis menerapkan metode ini di warnet game, tentunya user Game tidak akan bermasalah lagi karena ping latency akan tetap aman dan stabil karena para downloader sudah tidak bisa seenaknya ngabisin bandwidth :)
- Lalu Bandwidth Management Mikrotik HTB ini sifatnya dinamis, jadi apabila hanya satu atau dua user yang online maka user tsb akan mendapatkan bandwidth yang maksimal dan apabila semua user online makan bandwdith akan terbagi rata dengan sendirinya.

Contoh HTB
Dibawah ini script untuk menerapkan HTB sesuai dengan artikel saya diatas yang sifatnya sangat dasar sekali. silahkan apabila pembaca ingin memodifikasi atau utak atik sendiri script dibawah ini.
“Saat anda memberikan sedikit kepada sesama, maka anda akan mendapat banyak dari Dunia.”
#Definisikan network LAN agar tidak terlimit bandwidth lokalnya
/ip firewall address-list
add address=192.168.1.0/24 disabled=no list=lokal
#Buat Mangle
/ip firewall mangle
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.2 new-packet-mark=client.2 passthrough=no src-address-list=\
!lokal
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.3 new-packet-mark=client.3 passthrough=no src-address-list=\
!lokal
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.4 new-packet-mark=client.4 passthrough=no src-address-list=\
!lokal
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.5 new-packet-mark=client.5 passthrough=no src-address-list=\
!lokal
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.6 new-packet-mark=client.6 passthrough=no src-address-list=\
!lokal
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.7 new-packet-mark=client.7 passthrough=no src-address-list=\
!lokal
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.8 new-packet-mark=client.8 passthrough=no src-address-list=\
!lokal
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.9 new-packet-mark=client.9 passthrough=no src-address-list=\
!lokal
add action=mark-packet chain=forward comment=”" disabled=no dst-address=\
192.168.1.10 new-packet-mark=client.10 passthrough=no src-address-list=\
!lokal
#Buat Queue Tree Parent
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=2M name=AllDownload parent=global-out \
priority=8
#Buat Queue Tree Child
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.2 packet-mark=client.2 parent=AllDownload \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.3 packet-mark=client.3 parent=AllDownload \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.4 packet-mark=client.4 parent=AllDownload \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.5 packet-mark=client.5 parent=AllDownload \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.6 packet-mark=client.6 parent=AllDownload \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.7 packet-mark=client.7 parent=AllDownload \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.8 packet-mark=client.8 parent=AllDownload \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.9 packet-mark=client.9 parent=AllDownload \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=200k \
max-limit=512k name=PC-Client.10 packet-mark=client.10 parent=AllDownload \
priority=8 queue=default

Sekali lagi, langkah tsb di atas adalah hanya setingan standart HTB, untuk setingan yg lebih optimal lagi bisa mampir ke Jasa Setting Mikrotik

Sedikit kutipan dari artikel Bung Valens untuk sekedar mengingatkan pembaca akan syarat untuk terpenuhinya metode Bandwidth Management Mikrotik HTB
Yang perlu diingat mengenai Setting HTB Mikrotik:

  1. HTB hanya bisa berjalan, apabila rule queue client berada di bawah setidaknya 1 level parent, setiap queue client memiliki parameter limit-at dan max-limit, dan parent queue harus memiliki besaran max-limit.
  2. Jumlah seluruh limit-at client tidak boleh melebihi max-limit parent.
  3. Max-limit setiap client harus lebih kecil atau sama dengan max-limit parent.
  4. Untuk parent dengan level tertinggi, hanya membutuhkan max-limit (tidak membutuhkan parameter limit-at).
  5. Untuk semua parent, maupun sub parent, parameter priority tidak diperhitungkan. Priority hanya diperhitungkan pada child queue.
  6. Perhitungan priority baru akan dilakukan setelah semua limit-at (baik pada child queue maupun sub parent) telah terpenuhi.
Panduan praktis cara perhitungan limit-at dan max-limit
Di asumsikan bandwidth yang tersedia sebesar 2000kbps. Dan jumlah seluruh client adalah 10.  Yang perlu diketahui adalah :
  1. Berapa jumlah maksimal client yang menggunakan internet pada saat yang bersamaan. Jumlah ini belum tentu sama dengan jumlah komputer yang ada, apabila semua client tidak pernah terkoneksi secara bersamaan. Sebagai contoh, untuk kasus ini kita asumsikan adalah 10.
  2. Berapa jumlah minimal client yang menggunakan internet pada saat yang bersamaan. Sebagai contoh, untuk kasus ini kita asumsikan adalah 4
Maka, untuk setiap client (1 client dibuatkan 1 rule queue), limit-at nya adalah 2000 / 10 = 200kbps, dan max-limit nya adalah 2000 / 4 = 512 kbps.
Jangan lupa untuk menambahkan parent dengan max-limit sebesar 2000kbps (tidak perlu limit-at), dan memasukkan semua queue client di bawah parent queue. Jika untuk terminal tertentu membutuhkan priority lebih besar, maka kita bisa menggunakan priority yang berbeda-beda, tergantung dengan urutan prioritasnya.

Tuesday, January 5, 2016

45+ Social Bookmarking/News Sites You Should Consider

  • BibSonomy:BibSonomy is run by the Knowledge Data Engineering Group of the University of Kassel, Germany. It’s specifically designed for researchers to share bookmarks and bibliographies
  • Blinklist: A social bookmarking site launched by Mindvalley. According to their site, they launch several web businesses a year and are focused in 3 areas. – Technology, media and Marketing. BlinkList does have a user-friendly interface indicating that its being run well and efficiently. They also quote “fully profitable” on their site. Furthermore, you can label and comment about any web page on the Internet.
  • BlogBookMark: Designed specifically for Blog hunters, BlogBookmark.com claims to have the hottest news, gossip, and blog chatter from around the web. I highly sugggest that mainstream bloggers bookmark their entire sites here.
  • blurpalicious: Get Blurped! Not too different from other social bookmarks, but I love the tagline.
  • Clipclip: Clipclip allows you to save images and text, with a “bookmarklet”.
  • Cloudytags: A unique word analyzer connects to your page, gets all the words and suggest you the real tags your site is showing to the world
  • delicious: THE social bookmarking site. It allows you to easily add sites you like to your personal collection of links and to categorize those sites with keywords. Not to mention that if enough people save your site in a bookmark, it will make their popular page and send a lot of traffic. Delicious is owned by Yahoo and is a MUST for your social media and bookmarking strategy.
  • Diigo: Social bookmarking on steroids.
  • Digg: The social news site that changed the Internet, Digg is a high power authority and a listing in Digg for a site, even if it only has a couple of votes, will rank highly on Google and other search engines for certain terms. If your site is shared and voted upon on Digg, and makes the Digg homepage, you’ll get a lot of traffic and attention from other bloggers who read Digg.
  • Bookmark-manager: Organizer for bookmarks, calendar, diary and knowledge.
  • Bookmax: You can store your bookmarks and links to your favorite sites online and access them from wherever you are : basic Social Bookmarking.
  • Buddymarks: The online personal, group and social bookmarks manager.
  • lifelike: A free service to help academics to share, store, and organise the academic papers they are reading.
  • Dropjack: DropJack.com is a social content website and owned by the ExactSeek company.
  • Easybm: Allows users to bookmark their frequently visited sites on their private page, allowing 1-click access to their favorite web sites.
  • ez4u: Social Bookmarking – Ez4u to Bookmark : “Ez4u to Organize Ez4u to Share with Others Ez4u to Remember”
  • Favoor: Favoor is your personalized new start page. Collect your favorite internet addresses.
  • Folkd: Folkd is a social web-service about pages, news, audios, videos and blogs.
  • Freelink: Freelink.org provides free pages of links that you can access anywhere at anytime.
  • Furl: Like Delicious, LookSmart’s Furl.net is one of the first social bookmarking sites and considered an authority by the major search engines. Listing your sites in Furl will lead to traffic from organic rankings and its popular page drives traffic.
  • Gather: Gather is a place to contribute articles and content, blog, tag and connect with people who share your passions. (Plus you can link out from the articles in this authority site).
  • Google: Allows users to save and create bookmarks in their Google toolbar that can be accessed anywhere online. Google is getting more social by the day, so take advantage of their Google bookmarks and citations, because one day they probably will have some kind of influence on external meta data considered by the Google ranking algorithm.
  • Hyperlinkomatic: This is a bookmark list manager.
  • i89.us: i89.us offers a free service which allows you to save your favorite website/links at one location that can be accessed from anywhere.
  • Kaboodle: Kaboodle is a 2.0 shopping community where people recommend and discover new things.
  • Kinja: Kinja is a blog guide, collecting news and commentary from some of the best sites on the web.
  • Lilsto: Lilisto lets you store, manage and find your favorite links (or bookmarks) and removes the need to maintain them through your browser.
  • Linkagogo: Favorites and Social Bookmarking Application, its unique dynamic toolbars automatically adapt themselves.
  • Linkarena: German Social Bookmarking site.
  • Markaboo: MarkaBoo is tool for saving websites, files, and notes from your browser, email or mobile phone.
  • Memotoo: Lets users centralize and share your personal data.
  • Mister Wong: Mister Wong is a social bookmarking site that originated in Germany, and has since become a popular and widespread tool.
  • Murl: My URLs is a free online bookmarks manager, think of it as a bookmarks community.
  • MyBookmarks: MyBookmarks – access your bookmarks anytime, anywhere. Free productivity tool for business, student or personal use. Another popular bookmarking site.
  • Myhq: Store your bookmarks in one central location. Fast, text-based, banner free!
  • MyLife: A social search engine where users can find others
  • mySiteVote: mySiteVote is a community where you can vote your favorite site/s and view how popular a site is.
  • MyWebDesktop: A collaboration and communication tool, designed to be as generic and easy to use as a telephone and email.
  • Newsvine: The mission of Newsvine is to bring together big and little media in a way which respects established journalism.
  • Icio: Danish bookmarking engine.
  • Ikeepbookmarks: Popup feature allows you to add links while surfing the web
  • Iloggo: Simple web-based bookmarking tool that you can use for attractively displaying your favorite websites on one page.
  • Reddit: Timely and shocking news oriented, Reddit stories are instantly voted upon and if liked by the community as a whole, can drive incredible traffic and users.
  • Segnalo: Italian Social bookmarking site.
  • Sitebar: A solution for people who use multiple browsers or computers and want to have their bookmarks available from anywhere without need to synchronize them
  • Sitejot: Free online bookmark manager. Like every other social bookmarking site, it allows users to manage all of their bookmarks online in one convenient place.
  • Startaid: I’ve noticed that StartAid bookmark pages rank highly in Google and other search engines. This basic bookmarking service allows users to describe, tag and categorize sites.
  • StumbleUpon: Owned by eBay, StumbleUpon is an amazing blend of social bookmarking, voting, networking, web surfing, search and blogging. Best of all, StumbleUpon can send major traffic with its userbase of around 3 million users.
  • Stylehive: The Stylehive is a collection of all the best products, brands, designers and stores discovered and tagged by the Hive community
  • Tagza: A very young Social Bookmarking site mostly being used by Indian and Pakistani web masters.
  • Whitelinks: Securely store and quickly access favorite websites whenever connected to the Internet,:
  • Slashdot : The godfather of social news, SlashDot bookmarks are still quite powerful .. keep in mind the site has a heavy slant towards Linux and Open Source issues.
  • Squidoo: Kind of spammed out, Squidoo is a 2.0 property which lets people and businesses set up a ‘lens’ which lists links, tags and relevant RSS feeds to different subjects.
  • Wirefan: Social bookmarking, news articles submission site.:
  • Xilinus: Organize and manage bookmarks online.:
  • Yahoo! Bookmarks: Easily one of the most popular social search and bookmarking service on the web. It’s similar to Delicious and something they launched before acquiring Delicious. Yahoo Bookmarks lets users store bookmarks using their Yahoo Toolbar and access them from any computer.